Dear DeamonHunter. Re: Sprinkler Mod

Discussion in 'Staxel Discussion' started by Ellie, Aug 31, 2017.

  1. Ellie

    Ellie Member

    It doesn't seem to work, for me at least, after this last update. Is it just me or are there issues?

    If anyone else is having issues, and really misses huge crops watered via sprinklers, you can alter the weather files to make it rain all the time :)
     
  2. DeamonHunter

    DeamonHunter Member

    Heya, easiest way to reach me is to ping me on our discord.

    From what I can see, the mod is still working fine on the latest version of Staxel. Its by design that it takes time to water crops, and it will water all the squares eventually. (It won't water a tile that is already watered until it goes through all tiles.)

    Though I would like it to have a catch all and water on night transition, but that won't be happening any time soon.

    *Edit*
    Forgot to mention that it doesn't water when it's unloaded, which is an issue I know about but again the fix may not be any time soon.
     
    Last edited: Sep 1, 2017
  3. Ellie

    Ellie Member

    Thank you for the reply :D

    The issue is on my end then. I can no longer install mods using mod manager as I get an error :(, and they are not available in the game :(:(. I'll see if I can figure out what's going on.
     
  4. DeamonHunter

    DeamonHunter Member

    What's the issues with the mods? As in what error are you getting?
     
  5. Ellie

    Ellie Member

    I got the sprinkler one sorted and it's now in my game :D, completely a user error. For the coloured items mod, when I try to unpack it I get "F:/Users/Ellie/AppData/Local/Staxel.Launcher/gamedata/content/../LocalContent/packages/mod65_coloured_items.sxlmod: Root directory for mod package not found! Package is not valid." The same error for the western gates and fluorescent lights.

    When I open mod manager I get essentially the same message, then Panda Antivirus flags mod manager as a virus and quarantines/deletes it o_O Right after trying to unpack those last two mods Panda flags a UDP flood, don't know if those are related somehow as I'm not fluent in these things.

    Mod Manager is on the allowed list, and Panda still quarantines it after trying to install those last two mods. I have no idea how to tell Panda that the mods are allowed, since as soon as it detects the flood it springs into action... again, if it's related at all.
     
    Last edited: Sep 3, 2017
  6. DeamonHunter

    DeamonHunter Member

    Ah ok that error.

    A number of mods went on the workshop before we had the double click to add to staxel thing. A number of these mods (Including mine apparently, I completely forgot.) are actually being renamed from .zip to .sxlmod. The way to fix this is to change it back to a .zip and then extract it. (Some of these have an actual .sxlmod inside of them. You can double click that one.) And make sure that the /localcontent/ folder is clear of these "broken" ones.
     
    Ellie likes this.
  7. Ellie

    Ellie Member

    Okay, so I did as you said above. I have no idea what any of these means, but my game broke again. I'm hoping user error only?


    [​IMG]
     
  8. DeamonHunter

    DeamonHunter Member

    Basically this means my mod is outdated. I didn't realise it was this outdated. This should be resolved in about ~6 hours from now, and you won't need to deal with renaming the thing as I'll fix that as well. Other mods may have suffered a similar fate though.
     
  9. Ellie

    Ellie Member

    Oh nice, thank you!

    Yup, there's a couple more that are broken.

    Thank you again for your time!
     

Share This Page