Modding Guide

Discussion in 'Modding' started by EGadd, Jan 22, 2016.

  1. EGadd

    EGadd Developer Staff Member Staxel Developer

  2. Rossi123

    Rossi123 New Member

    i just tried to follow the instructions in the modding guide but there is one problem. When i'm in the asset manager, i go to "asset" and click "add" and then "clone asset" like you said in the modding guide but when i click "clone asset" there comes up a message that says:

    "Unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. if you click Quit, the application will close immediately.
    Constructor on type 'Staxel.AssetManager.AddAssetTypeChoiceDialog'1[[Staxel.AssettManager.TileAssetControlData+TileAssetType. Staxel.AssetManager. Version=1.0.0.0. Culture=neutral. PublicKeytoken=Null]]' not found.

    And i clicked Continue but i dont think anything happened cause no box opened after that, the only box that was open then was the one before i tried to do that.
     
  3. DeamonHunter

    DeamonHunter Member

    Thanks Rossi, I just fixed this in our dev build and should be ready to go once we get out our next update. Sorry for not getting to this earlier.
     
  4. Ellie

    Ellie Member

    I wanted to mod in some extra recipes using Asset Manager, but there doesn't seem to be a way to do this. I can't seem to change milk to water, or pumpkin to cabbage. I also can't simply change the code for a new recipe and add it to the list in cooking/soup. Is recipe creation not a thing or am I doing it wrong?

    Edit: in the "assetbinding collection editor", under item (where there would be, for example Spawned item: staxel.item.crops.pumpkin, how do I insert staxel.item.crops.cabbage instead?

    Cancel the first edit, figured out how to change everything once I dug a little bit:rolleyes: Now a new issue. When I build and validate I get a slew of these windows:

    http://imgur.com/IDG6xcx (tried posting the picture, but it wouldn't work this time around)

    The game appears to work, but the error messages do make me concerned I somehow broke my game in ways a short test doesn't show.
     
    Last edited: Aug 16, 2017
  5. DeamonHunter

    DeamonHunter Member

    I'll check out these errors. This looks like it is just an issue with the AssetManager and not the game.

    For now if you want to avoid the scary errors, try just running ContentBuilder.exe instead of Building and Validating in AssetManager.
     
    Ellie likes this.

Share This Page