World will not launch most of the time

Discussion in 'Support' started by Mira, Apr 19, 2018.

  1. Mira

    Mira New Member

    I removed Staxel from the Nvidia drop down and reinstalled it. It launched once and it worked, then refused to launch again after that. After the first successful launch, it just kept throwing up the red error box. It seems to be very hit and miss and totally random - once in a blue moon it will launch, the rest of the time it won't. Same goes for launching the actual world.

    When it did launch the one time, before it broke again, I created a new copy of my world. I also tried to create a completely blank world. None of the three worlds would launch - the blank one wouldn't even create. All worlds crashed with the same messages from the start of the thread. I tried a few times.

    If it helps, I'm running a gaming laptop and I have a dozen other games which all load and play first time, every time with no problems. I'm not sure why Staxel suddenly stopped working and why the fixes don't appear to be working either.
     
  2. Badger

    Badger Moderator Staff Member Staxel Developer

    Hi, really sorry that you're having so many issues. I've been wracking my brain to try and think of what would be causing it if none of the other fixes are working. The only thing I can think of is that some 3rd-party application is interfering with Staxel. Your PC specs are fine, and seeing as you can launch the game on the rare occasion and have had it working without issues in the past it's pretty clear that your system is capable of playing it.

    There's a testing version on the beta branch on Steam that might be worth a try (if open the Staxel properties window within Steam it's under the Betas tab - no password required).

    Other than that, I'm posting this thread in the devchat to see if anyone else has any ideas. Would you mind letting us know your Steam username to make it easier to find the logs you've submitted?
     
  3. Badger

    Badger Moderator Staff Member Staxel Developer

    What happens if you launch using the "Launch Dedicated Server" option in the popup, and then press "Start Server" at the bottom?
    Alternatively, going to Program Files (x86)\Steam\steamapps\common\Staxel\bin and launching the "Staxel.Server" application (green icon)
     
  4. Mira

    Mira New Member

    Alternatively, going to Program Files (x86)\Steam\steamapps\common\Staxel\bin and launching the "Staxel.Server" application (green icon)

    It tries to launch but then error box: 'Staxel.Server has stopped working'.

    Managed to get the game to launch today by right clicking in Steam and clicking 'Launch (compatibility)'. However, the first time I tried to load a world it did the 'Sorry, exception' message and then the second time it did actually go to the loading screen but then it just got stuck there and never actually loaded.

    My log in username is sangaku28 and my player name is Mira. I don't always submit logs but I'm doing some fresh ones for you now. After the attempt I just told you about I tried to send crash logs and got a red message saying that it had failed to send crash logs. Then it asked if I wanted to send feedback re: crash logs failing to send and I did and I think it went but I have no idea what you actually got!

    The game appears to be loading fairly consistently today but the world won't launch. I've done a few launches and submitted all the logs for you.
     
  5. Badger

    Badger Moderator Staff Member Staxel Developer

    Okay we've had a look at the logs, thanks.
    They all show that the server process is failing to launch. Something is causing the server aplication to crash as soon as it starts up (it's why you can still get into the game but are getting errors when trying to start a world).

    Again, this is almost always down to Antivirus. Do you get the crash when you've got your antivirus disabled?
    When you added Staxel to Kaspersky's exceptions did you add the whole Staxel folder from ../steamapps/common/ or did you just add the Staxel application?
    You could try adding these two to the exceptions as well:

    C:\Program Files (x86)\Steam\steamapps\common\Staxel\bin\Staxel.Server
    C:\Program Files (x86)\Steam\steamapps\common\Staxel\bin\Staxel.Server.NoConsole

    (obviously your install location may be different, that's just the default path for Steam games)
     

Share This Page